1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Forum Maintenance

Discussion in 'About Arkadia Forums' started by Snape, Oct 13, 2013.

  1. Snape

    Snape Master of the BanHammer Staff Member PAF Administrator

    Messages:
    4,233
    Likes Received:
    372
    Trophy Points:
    83
    Hi Folks,

    Just to let you all know that I'm planning on doing some upgrades and maintenance on the forum. EDIT (Snape): DONE!

    This will be to put the latest patches in place after the recent hacks we experienced and to plug some other exploits that have apparently been found by the devs at VBulletin.

    When I do this, I will be temporarily taking the forums offline so when you try to login you should see a message from me ;)

    Also, due to the custom skins we use, there may be some instances of breakage when I do this so if things go a little squirrelly, then this is the reason for it. I will endeavour to fix it all quickly, but if you spot any issues, please let me know here.

    Hopefully the downtime will be minimal.

    Finally, due to the recent hacks and the bloated and customisation unfriendly nature of VB, we are considering changing the forum engine completely to XenForo. Those of you that are members of EntropiaPlanets will be familiar with this forum engine and know how clean and shiny it is. The decision to do this hasn't been firmly made yet so don't panic, but I just thought I'd give you the heads up that we are considering it.
     
  2. Snape

    Snape Master of the BanHammer Staff Member PAF Administrator

    Messages:
    4,233
    Likes Received:
    372
    Trophy Points:
    83
    Well,

    Due to Chris spotting another hack effort, I've had to completely alter my plans today and perform the updates I was intending to do next week!

    A few of you may have noticed the forums go down a little while ago, but things went smoothly for the most part and we are now updated and back online.

    HOWEVER!

    I've had to temporarily disable the Thanks/Like post feature plugin as it caused problems. I have already downloaded the latest version which purports to fix the issues and will sort that out (hopefully) later this afternoon once I've returned from getting some X-Rays done and new tyres on my car!

    If you observe any other problems, please post here in this thread regarding them (with screenshots if you could) and I will address them as they pop up.

    Thanks once again for your patience in this matter

    Now back to our regular programming......
     
    • Like Like x 1
  3. Snape

    Snape Master of the BanHammer Staff Member PAF Administrator

    Messages:
    4,233
    Likes Received:
    372
    Trophy Points:
    83
    Ok, another update for y'all.

    The Thanks/Like is still disabled (as the update didn't fix the issues like it said it would) and TBH I'm thinking of not reenabling it as it really didn't add that much function to the forum overall.

    The Gallery is also disabled for the time being for the same reason. We are looking into a newer version or a different version but that depends on ongoing discussions regarding changing the forum engine.

    Everything else should be back to normal, but let me know if you find anything.
     
    • Like Like x 1
  4. Venture Bros

    Venture Bros Member

    Messages:
    97
    Likes Received:
    0
    Trophy Points:
    6
    Thanks for the hard work!
     
  5. Snape

    Snape Master of the BanHammer Staff Member PAF Administrator

    Messages:
    4,233
    Likes Received:
    372
    Trophy Points:
    83
    Cheers, much appreciated.

    ****************

    The rep system is apparently giving an error on use. It looks like some sort of database error, but the system is still working and rep is still being given.

    We're looking into this and will fix it as soon as possible.
     
  6. Snape

    Snape Master of the BanHammer Staff Member PAF Administrator

    Messages:
    4,233
    Likes Received:
    372
    Trophy Points:
    83
    Apparently some people using IE (yuck! why would you do this to yourself?!) or FireFox or Safari on the iPhone are having display issues with the forum. I've so far been unable to reproduce this myself but I'm working on it slowly and will see if i can update the mobile version of the forum to see if that fixes it.

    I'm in a run of night shifts again atm so don't expect miracles before Friday ;)
     
  7. Snape

    Snape Master of the BanHammer Staff Member PAF Administrator

    Messages:
    4,233
    Likes Received:
    372
    Trophy Points:
    83
    Ok, people, some updates for you.


    • The mobile version of the forum is updated to version 4.2.2!!! :cowboy: - If you are accessing PAF from a smart phone, I'd suggest using the mobile version in preference to the full site. If you've previously clicked "Full Site" on the mobile version and cant get back, delete your browser history and make sure you are logged out of the forum, then go to the forum on your phone and this should automatically take you back to the mobile version.


    • I have altered the Player Essentials Dev Posts on the front-page to replace Cyrus with Chris. Cyrus's posts are still here on the forum though so you can do a search for "Cyrus" in the memberlist if you want his posts for anything.


    • Lastly, with all the hassle of things breaking with the last update and the pain in the rear it is proving to be to fix so much of it (I have really grown to hate VB in the last week!), we will be changing the forum at some near future point to use the XenForo engine.:dribble:

    I am in the process of purchasing a license, the mods/addons I think we will want for PAF and establishing a test server onto which I will then be copying the existing database to see how things go with a straight conversion. Once this has been tested thoroughly and I am 100% ready, I will let everyone know so that you have at least a weeks notice of the impending changes. I will then close the forum down, like we do normally during maintenance, so that no changes/new posts etc creep in and cause database errors during the change over. I will then bring things on-line one at a time so we will start with basic functionality and work up from there.​
     
  8. Snape

    Snape Master of the BanHammer Staff Member PAF Administrator

    Messages:
    4,233
    Likes Received:
    372
    Trophy Points:
    83
    For those interested, I have enabled non-members and people awaiting email confirmation to be able to see thumbnails and pictures. Let me know if it is still causing issues.
     
  9. May

    May Active Member

    Messages:
    908
    Likes Received:
    229
    Trophy Points:
    43
    Thank you very much for changing that. It works fine now from here.
    And I apologize for nitpicking you into more work. :eek:
     
  10. Snape

    Snape Master of the BanHammer Staff Member PAF Administrator

    Messages:
    4,233
    Likes Received:
    372
    Trophy Points:
    83
    Lol, don't worry, I'm my own worst enemy when it comes to work. I try to avoid work as much as possible, but I seem to attract it like a bloody magnet!
     
  11. May

    May Active Member

    Messages:
    908
    Likes Received:
    229
    Trophy Points:
    43
    Ah, things like that are like cats: they always jump on the lap of the persons who really don't like them.

    But seeing you don't mind ;), here's another one:
    Has something changed again for the image permission setting?

    When it was changed the first time, it was possible to see the thumbnails and pictures even when not logged in.
    Now you can see the thumbnails, but seeing the pictures requires a log in again.

    I also noticed that someone was able to create a new album. Since they are linked to the gallery, and that was offline; something must have changed there as well?
    Or is this the reason that now the pictures are blocked once again?
     
  12. BB Global

    BB Global Member

    Messages:
    90
    Likes Received:
    2
    Trophy Points:
    8
  13. Snape

    Snape Master of the BanHammer Staff Member PAF Administrator

    Messages:
    4,233
    Likes Received:
    372
    Trophy Points:
    83
    I haven't changed anything since I altered the permissions for non members to see pics. Can you give me a rundown of what you were doing at the time you have each of these problems?

    So when you aren't logged in, you can see thumbnails but if you click them it tells you to login?

    Also, the gallery is still offline and will be for the foreseeable future until 1 of 2 things happen: 1 I get an update for the gallery plugin we used, or 2, we change to the new forum engine.

    Its possible people know the direct URLs of their pictures in the albums and can access them that way as all teh images are still there, its just the actual plugin that is not working currently.

    I can't really do much till at least the weekend anyway, but the more info you guys can give me the faster I can workout what needs doing.
     
  14. May

    May Active Member

    Messages:
    908
    Likes Received:
    229
    Trophy Points:
    43
    Yeah, exactly that: now when not logged in, I can see the thumbnails in the posts, but when clicking on them to open them, it takes you to a log in screen.

    And I'm aware that there is a forum engine change coming; I'm not asking for, or expecting any changes in the current forum.
    Just was wondering: if you can create new albums, then something has to be online at the moment, right?
    Because not only were these pictures added yesterday, but the albums themselves were created yesterday too.
    And I thought that was impossible to do as long as the gallery was offline?
     
  15. Snape

    Snape Master of the BanHammer Staff Member PAF Administrator

    Messages:
    4,233
    Likes Received:
    372
    Trophy Points:
    83
    Sorry May, I was having a DERP moment. Albums are not connected to the Gallery plugin we were using. If you go to the "Community" dropdown just under the tabs at the top of the forum page you should see Albums as the second menu entry.

    I'll have another look at the permissions for viewing pics and see if I inadvertently changed something I didn't intend to.
     
  16. Snape

    Snape Master of the BanHammer Staff Member PAF Administrator

    Messages:
    4,233
    Likes Received:
    372
    Trophy Points:
    83
    Just looked at the permissions again. I've changed an option allowing non-members and not logged in people to be able to download attachements as well as being able to view thumbs. Hopefully this should solve it as there is no other option pertaining to images.
     
  17. May

    May Active Member

    Messages:
    908
    Likes Received:
    229
    Trophy Points:
    43
    Aw, sorry to bother you again, but... yay, it's fixed now.
    I can see the thumbnails and the pictures without the need to log in. So visitors should be able to also.

    And about the gallery: in your place I would most probably have a lot more 'DERP' moments than that.
    I tip my hat to people that volunteer so much free time, whatever the reasons for it may be. View attachment 8321
     
  18. Syrinx

    Syrinx New User

    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    Nice to see so much open communication on the website maintenance. And very nice forum it is too, thanks for all your hard work :)
    ~Syrinx
     
  19. Snape

    Snape Master of the BanHammer Staff Member PAF Administrator

    Messages:
    4,233
    Likes Received:
    372
    Trophy Points:
    83
    Thanks Syrinx. It would be a lot easier if VBulletin didn't cock up our templates and formatting each and every time we did a patch. This is the reason we will be changing to XenForo in the near future...If I can get my rear in gear and get it organised.....So much work, so few hours in a day :(
     
  20. Snape

    Snape Master of the BanHammer Staff Member PAF Administrator

    Messages:
    4,233
    Likes Received:
    372
    Trophy Points:
    83
    Bit of an update for you folks. In an effort to track down the bit that is causing problems for us here at PAF I have uninstalled a number of plugins that we had running (such as an extended rep system and the thanks/Like hack).

    Unfortunately the rep plugin did not revert to a working default so for now I have completely switched off the rep system until I can sort it out.

    Also, there are still a number of plugins running (such as the chatbox) which I will eventually uninstall in an effort to fix it/rebuild it and then install newer or better versions. However, my main idea is to keep us as lean as possible with addons so that we dont encounter this nonsense everytime there is a security update or patch.

    Additionally, there is another patch to be done on the version of VB we are running, which I will do over the next couple of days. So if you find the forums down at some point, you know its just me fiddling.

    There is a distinct possibility that I will have to delete a lot, if not all of the custom templates we previously used in order to get things working again. This means that things like the different skins etc will revert to the default VB ones until such time as I can fix it all and then rebuild some new skins.

    As always, thankyou in advance for your patience and understanding.
     

Share This Page